Troubleshooting Tips(If your Part History Disappears (Very Rare) )

On two rare reported occasions, a part's history became corrupt and "disappeared" for unknown reasons.  If this happens, you can attempt to find and recover the part history as follows:

1. Set the part filter to "Feature". 
 

2. Right-click on any geometry that will highlight and select the "Inquire" option.  ZW3D will bring up the information about the feature (i.e. history operation) associated with the geometry.  If your part file is not totally corrupted, the feature is still associated with the group of features that constitute the original history. 
 

3 Use the "Previous" button on the "Inquire Entity" form to step backwards through the feature list until you arrive at what you think is the first feature in the history, which is usually the "XY" datum feature. 
 

4 Note the entity id of the feature shown on the "Inquire Entity" form. 
 

5  Reattach the history that starts with this feature by typing:

"$$SetHistIdx XX"

from the ZW3D command line (without the quote marks), where XX is the integer id of the starting feature (e.g. $$SetHistIdx 99). 
 

6  Take down the "Inquire Entity" form and bring it back with a for the default entity, which is the active target part. 

See whether the "history" field of the active part references the feature you entered using $$SetHistIdx. 
 

7  Now, take down ZW3D Data Manager and then put it back up to see if the history is redisplayed.  If so, then there's a chance you successfully recovered the part history!


© 2013 ZWCAD Software Co., Ltd. All rights reserved.
All trademarks, trade names or company names referenced herein are used for identification only and are the property of their respective owners.