CAD/CAM discussion forum > ZW3D CAM > Ghost tool paths

Ghost tool paths

Rank: 1

Didier

Newbie

posts: 35

Registered: 2011-9-9

Message 1 of 10

 Ghost tool paths
20-03-2013 09:07 . pm | View his/her posts only
Hi,

We are still testing the beta, maybe this issue has been solved in the final release.

When we calculate a tool path, other tool paths randomly disappear:

-when the mouse cursor leaves the CAM manager zone, some tool paths disappear from the main window
-these tool paths are also missing in the solid verify dialog box

The only way we found to work around this issue is to re-calculate all tool paths.

Hopefully, it's pretty fast as they probably are still cached, but when you have numerous tool paths it's difficult to see if some are missing.

Can somebody confirm this issue?

Has it been addressed in the final release?

TIA

Rank: 1

ZW3DUser

Newbie

posts: 59

Registered: 2013-2-8

Message 2 of 10

20-03-2013 11:35 . pm | View his/her posts only
Post Last Edit by jansen1776 at 2013-3-20 23:37

Can you make an screenshot ?
I have some "ghost toolpath" if i calculate an operation, edit some settings and calculate again. This "ghosts" will be removed if you close the settings and go bak to the settings, or you can pusch to the button an the bottom of the settings page, right next the light bulb.

The final version is out now, but make they ANY fixes ?

Rank: 1

Didier

Newbie

posts: 35

Registered: 2011-9-9

Message 3 of 10

20-03-2013 11:54 . pm | View his/her posts only
Reply 2# jansen1776


Ghost was probably not the best word. I mean that when we calculate one path, another calculated path disappears. It seems still calculated in the manager, but disappears from the graphical main view and from the solid verify dialog box.

Difficult to make a screenshot, as it disappears :)

Rank: 1

ZW3DUser

Newbie

posts: 59

Registered: 2013-2-8

Message 4 of 10

21-03-2013 02:58 . am | View his/her posts only
Do you tested the button i wrote ?

Rank: 1

Didier

Newbie

posts: 35

Registered: 2011-9-9

Message 5 of 10

21-03-2013 05:01 . pm | View his/her posts only
Post Last Edit by CoReForm at 2013-3-21 17:04

Post Last Edit by CoReForm at 2013-3-21 17:04

Reply 4# jansen1776


Hi,

Yes, I tested this button, but it is only a Redraw button. The issue is not only a display problem.

I hope the attached screenshot will clarify.

Ghost path

erreur ZW3D 2013.JPG
2013-3-21 16:56


In the Manager tab, all path tools have the calculated icon, with the little red lines. 11 paths have been calculated.

But in fact, some calculated tool path disappeared. Not only they vanished in the 3D view, but it's not only a display issue, as they also disappear from the Solid verify dialog box, where only 8 toolpaths remain available in this case.

We have to recalculate all toolpaths each time this occurs. And it occurs as soon as we have a few toolpaths.

Rank: 5Rank: 5

Tony_ZWSOFT

posts: 44

Registered: 2011-8-22

Message 6 of 10

22-03-2013 02:48 . pm | View his/her posts only
Hi Didier,
Thank for the testing and feedback.
FYI, we have released the official version on 18th march.
Please download the installation file from following link:

http://download.zwsoft.com/zw3d/ZW3D2013/ZW3D2013Eng.exe

could you send us the file, then we can check it if the problem still appear in offical version.

Our technical support email addree is ZW3D@ZWSOFT.COM.

Thank you.

Tony Tan

Rank: 1

Didier

Newbie

posts: 35

Registered: 2011-9-9

Message 7 of 10

22-03-2013 03:40 . pm | View his/her posts only
Hi Tony,

Unfortunately, our calendars did not match and we were not able to test the beta before last week.

As this forum seems active, and as the ZWsoft team participate, we will continue providing feedback.

Too late for the first release, but I hope you will continue to take user feedback into account for a SP1.

I won't have access to our test file until monday, but will test the final version ASAP.

All the best,

Didier

Rank: 1

Didier

Newbie

posts: 35

Registered: 2011-9-9

Message 8 of 10

25-03-2013 05:54 . pm | View his/her posts only
Reply 6# tony


Hi Tony,

Just sent the file to the address you provided.

It's a 4.5 MB file, so let me know if you have a problem getting it, I will provide a download link.

Best regards,

Didier

Rank: 1

Didier

Newbie

posts: 35

Registered: 2011-9-9

Message 9 of 10

01-04-2013 12:45 . am | View his/her posts only
Reply 8# CoReForm


Hi Tony,

We have to test more, but we didn't saw this issue with the final release.

Best regards,

Didier

Rank: 1

Didier

Newbie

posts: 35

Registered: 2011-9-9

Message 10 of 10

18-04-2013 03:05 . am | View his/her posts only
Reply 9# CoReForm


Hi Tony,

We did not encounter this bug with the final release of ZW3D 2013, after a few days of use. So, it seems this issue is solved.

We noticed also that some other glitches of the beta have disappeared in the CAM section (we don't use intensively CAD functions). Obviously, good work has been done before the final release.

Best regards,

Didier
See also