CAD/CAM discussion forum > 3D CAD/CAM > VX Help Search hangs VX on my Vista machine

VX Help Search hangs VX on my Vista machine

Rank: 1

OldForumPost

Newbie

posts: 0

Registered: 2012-1-14

Message 1 of 5

 VX Help Search hangs VX on my Vista machine
20-06-2008 09:28 . am | View his/her posts only
When I try to search for help topics in VX help I get the circle of redundity (my word) displayed by Vista indicating pending request. This goes on forever, until I call up Task Manager and have to use it to kill VX.
Otherwise the help hyper-links from one topic to another work OK.
VX is the only program I have this issue on!
Any suggestions?
Thanks

Rank: 1

ChrisWard2k2

Newbie

posts: 2

Registered: 2011-11-22

Message 2 of 5

20-06-2008 10:52 . am | View his/her posts only

Hi CoulDes

We clearly have something wrong as far as the Vista platform is concerned in that case. Very strange that the hyperlinks work though. The help is a compiled format (Robo Help), it should be immune from browser problems. It might be that the help pages of other programs you use do not work in the same way, but other VX Vista Users have not reported the same problem. If you switch on Help Interactive Mode, does that work?

Rank: 1

OldForumPost

Newbie

posts: 0

Registered: 2012-1-14

Message 3 of 5

20-06-2008 03:04 . pm | View his/her posts only
Chris,
I have solved the problem by finding VXhelp.chm in the user 13.5/doc directory, right click and pick Properties, click on security tab. There are 3 group or user names listed:
A) System: this show check marks for all permission items;
B) Administrators: this shows check marks for all permission items:
C)Users: This originally showed check marks for Read & execute and Read permissions; I have clicked on the Edit button to modify permissions and selected All. Now check marks show for permissions for everything except Special Permissions. After making this change I can now Search VX Help topics.

When installing VX, by the advise of P. Lamm I installed "As Administrator" in order to get VX to run. What I don't know is why the Users for VX 13.5 are not given permissions for the help file during installation.
Thanks,
John

Rank: 1

ChrisWard2k2

Newbie

posts: 2

Registered: 2011-11-22

Message 4 of 5

20-06-2008 04:44 . pm | View his/her posts only

Hi CoulDes

In the past, the VX User had to have administrator privileges. This was for a variety of good reasons from the VX side but ultimately not good in a corporate environment. We have changed this for VX on Vista, but you have found something we missed. I will raise a PCR to get the error corrected. Well spotted!

Rank: 1

Mike

Newbie

posts: 0

Registered: 2002-8-28

Message 5 of 5

24-06-2008 09:24 . am | View his/her posts only
John,

I cannot duplicate the problem with the standard installation. I have the same permissions you quoted and I am able to search. Are you using the default directories when installing the software? I believe the HELP file is in Program Files/VXCorp not the USER/VXCorp but using these directories should solve any permission issues.
See also