CAD/CAM discussion forum > CAD > Wipeouts in XREFS

Wipeouts in XREFS

    
  Subscribe Topic

Rank: 1

JMORENO5886

Newbie

posts: 4

Registered: 2012-10-30

Message 1 of 10

 Wipeouts in XREFS
10-04-2013 04:40 . am   |   View his/her posts only
Whenever I have an XREF in a drawing... If that xref has wipeouts, then the wipeouts affect my main drawing. Despite using XCLIP to clip the XREF.

When dealing with the same XREFS, if i do a selection window to move, edit, copy or erase. ZWCAD selects other XCLIPPED XREFS that were not part of the selection window I made.


This seem to be related in some way either to the basepoint of the XREF or to the fact that the XREF has wipeouts within the DWG.


Please help solve this issue as soon as possible given that I have to meet some deadlines and this is affecting my productivity.


Thanks!

Rank: 5Rank: 5

Jenny

posts: 25

Registered: 2012-2-11

Message 2 of 10

18-04-2013 04:25 . pm   |   View his/her posts only
hi, could to describe every steps in details?

Rank: 1

Sven

Newbie

posts: 11

Registered: 2011-9-23

Message 3 of 10

02-05-2013 03:48 . am   |   View his/her posts only
I sent a video and file to Zwcadusa illustrating this bug, I can send it to you but cannot find your email.

Rank: 8Rank: 8

Jenny

Super Moderator

posts: 523

Registered: 2013-5-6

Message 4 of 10

06-05-2013 05:03 . pm   |   View his/her posts only
Reply 3# Pavman


pls send to wuqiaojuan@zwsoft.com

Rank: 1

Sven

Newbie

posts: 11

Registered: 2011-9-23

Message 5 of 10

07-05-2013 09:47 . pm   |   View his/her posts only
Reply 4# Jenny_ZWCAD


I sent you a drawing with examples. Thank You.

Rank: 8Rank: 8

Jenny

Super Moderator

posts: 523

Registered: 2013-5-6

Message 6 of 10

09-05-2013 05:32 . pm   |   View his/her posts only
Reply 5# Pavman


hi, got your email, thank you for the drawing, it helped me to figure out the reason of this problem.
The problem is: after using xclip to clip the block reference, the deleted part should not be counted like the remaining part.

xclip.jpg
2013-5-9 17:30



When you select the upper left drawing by window selection, you drag your mouse from right to left, in this way, the objects will be selected even only part of it is included within the windows selection. And unfortunately, the deleted part of the xcliped-block-references in the other three remaining drawings are selected, then they are deleted although they seems non-selected(actually they are selected).

The problem ID is 5308, we will try to solve it. Before the problem is fixed, I suggest you to take one of following as temporary solution:

1. Select the upper left drawing by windows selection, be sure to select from left to right (in this way, the object will be selected if all of it is included within the window selection area), and then erase them, after that you will find that some xclip-block-reference in the upper left drawing are still there, then you can select them by picking, and then delete them.

2. This problem only happen on ZWCAD+ 2012, but not on ZWCAD 2012, please use ZWCAD 2012 as a temporary solution.

Rank: 1

JMORENO5886

Newbie

posts: 4

Registered: 2012-10-30

Message 7 of 10

09-05-2013 08:50 . pm   |   View his/her posts only
In addition to this, there seems to be an error when using XCLIP.If there is a text label, XCLIP will not "hide" the label if part of said label is visible within the window
See example below


xclip problem 2.jpg
2013-5-9 20:49

Rank: 1

JMORENO5886

Newbie

posts: 4

Registered: 2012-10-30

Message 8 of 10

09-05-2013 09:02 . pm   |   View his/her posts only
Problem Number 3:

If there is a wipeout within a drawing, if you xref it into another drawing and xclip said drawing, the wipeouts show up in the new drawing.

See Below
xclip problem 3.jpg
2013-5-9 21:02

Rank: 1

Sven

Newbie

posts: 11

Registered: 2011-9-23

Message 9 of 10

29-08-2013 04:33 . am   |   View his/her posts only
Reply 6# Jenny_ZWCAD


Hi Jenny, in case this issue got forgotten about, the latest release of Zwxad+ 2014 Beta 2. VERNUM = "2013.08.15(14973) still has the same issue. Is this that complicated of a fix, as it is really messing up our workflow???

Rank: 8Rank: 8

Jenny

Super Moderator

posts: 523

Registered: 2013-5-6

Message 10 of 10

29-08-2013 04:40 . pm   |   View his/her posts only
Reply 9# Pavman

Sven, this problem hasn't been solved, we are still working on it.
See also
X