CAD/CAM discussion forum > CAD Tutorial & Tips > How to load CAD LISP application on startup? how to load vba startup?

How to load CAD LISP application on startup? how to load vba startup?

    
  Subscribe Topic

Rank: 8Rank: 8

Jenny

Super Moderator

posts: 523

Registered: 2013-5-6

Message 1 of 3

 How to load CAD LISP application on startup? how to load vba startup?
22-06-2013 11:26 . am   |   View his/her posts only
How to load CAD LISP application on startup? How to load vba application startup?
In order to load CAD application automatically every time start CAD, we can add the application into startup suite.
Input command APPLOAD, click the Startup Suite button, then click Add button and browse to the application that you want to run it when CAD launch.

autocad application startup suit

app-startup-suite.jpg
2013-6-22 11:25



autocad load application

app-startup-suite-add.jpg
2013-6-22 11:25




You might also like these posts:
Some lisp routines for autocad or zwcad beginners.
ZWCAD Lisp FAQ
use lisp to convert line or arc to polyline
command alias editor for ZWCAD, CAD lisp program with dialog box
add support file search path lisp




Try ZWCAD+ free for 30 days:
http://www.zwsoft.com/zwcad+/

Rank: 1

mauric7000

Newbie

posts: 4

Registered: 2013-1-2

Message 2 of 3

20-07-2013 04:31 . am   |   View his/her posts only
Hello Jenny,
i've been trying to do that for months now and it never works.
First, I made a specific profile with the path for the app., load the specific menu, load the .lsp and put the main one in startup. While in "Option", press apply, then export to make the .arg file and then save the dwg in a working directory.
I think I didn't forget any thing, so I shut down ZWcad and open again and start a new session. Bad luck !
The profile is the default one, I have to go to "option", "profile", select the specific one, apply.
Ok.
Then go to load application, put back the main application in the commun list from startup to select it and load it. And, at last, it works.
In the same session, start a new dwg, the profile is ok but the app. is not load automatically neither in nor out of startup. It must be loaded manually. The thick "load zwcad.lsp in every dwg" is on, I've try to add a command in this file but it didn't do any difference.

Do you have any suggestion to make the app. loading smoother ? a script or a command that will executed at every start of session or dwg opening ?
Thanks in advance.

Rank: 8Rank: 8

Jenny

Super Moderator

posts: 523

Registered: 2013-5-6

Message 3 of 3

23-07-2013 03:34 . pm   |   View his/her posts only
Reply 2# mauric7000

There are two problems you reported.
1. lose custom profile

This is a problem of ZWCAD+ (issue ID: 5603). Before it is solved, you can try to troubleshooting by this way:
After "First, I made a specific profile with the path for the app., load the specific menu, load the .lsp and put the main one in startup. While in "Option", press apply, then export to make the .arg file and then save the dwg in a working directory." , run appload to load again, then restart ZWCAD+, the profile will be the custom one.

2. do not load zwcad.lsp in every dwg
After running appload to load the lisp, in the same session, and start a new drawing, the lisp doesn't run. This can be troubleshooting by restart ZWCAD+ after loadig the lisp. For the restarted ZWCAD+ session, every drawing load the lisp.
See also
X