CAD/CAM discussion forum > ZW3D CAD > imported step files coming black into ZW3D 2012 SP2

imported step files coming black into ZW3D 2012 SP2

  Subscribe Topic

Rank: 2


Assistant Engineer

posts: 73

Registered: 2013-1-16

Message 1 of 3

 imported step files coming black into ZW3D 2012 SP2
23-03-2013 06:02 . am   |   View his/her posts only
Myself and a friend both have duplicated this same behavior in ZW3D 2012 SP2.This is irritating with parts and very very irritating with assemblies.

Here's the sequence of what we do.

1. create a single part using default settings and color and save the part out as a *.z3 and as a *.step.
2. open the *.z3 and all is perfect.
3. read the *.step back into ZW3D (we call this a roundtrip) and the part is black.
4. go to a directory with 10 or so *.step files that were never in and were not saved as *.step out of ZW3D 2012 SP2.
5. about 5 of the parts open as they should (with correct colors) and the other 5 open with the part or parts black.

Has anyone else seen this ?

The good news is that these black parts do not happen in ZW3D 2013 or said another way whatever is wrong in 2012 has been fixed in ZW3D 2013.

Thanks much


Rank: 2


Assistant Engineer

posts: 73

Registered: 2013-1-16

Message 2 of 3

23-03-2013 07:55 . am   |   View his/her posts only
I did some more testing with a few other CAD programs.I did learn something new that solves the small part of this problem.

Please note that step has two versions (application protocols) AP203 and AP214

The small problem is from ZW3D saving the file out in step and round tripping it back in and it turning black. This may not done all that often. If your working in ZW3D it makes sense that you most of the time will save the part in *.z3 and bring it back in as *.z3

The larger problem is reading step files in to ZW3D that were created externally in another CAD program. This is the most common workflow. You get a bunch of step files to work on or modify in ZW3D.

I found that from ZW3D round tripping a part with with Step AP214 works fine.
Round trip the same part with AP203 and the parts are black.

The problem is still though the parts you get from externally. You have no control over whether the step files are saved as AP203 or AP214. Don't know about the rest of the world but in the US because it was the first protocol almost all step exporters default to AP203. This is a problem and explains when I ran a test of 10 step files that some came in good but most were black. Or said another way some were AP203 and some were AP214.

Again important to note is that for me these problems only exist in 2012.
None of this black part stuff in 2013.

Rank: 3Rank: 3


Junior Engineer

posts: 238

Registered: 2011-11-23

Message 3 of 3

23-03-2013 09:09 . pm   |   View his/her posts only
Hi , before 2012 not cerano these problems. 2013 Li has apparently solved
See also