CAD/CAM discussion forum > CAD > Delay getting license from license server

Delay getting license from license server

    
  Subscribe Topic

Rank: 1

s.meyer

Newbie

posts: 2

Registered: 2011-12-23

Message 1 of 4

 Delay getting license from license server
08-01-2017 04:50 . am   |   View his/her posts only
When ZWCAD 2017 (2016.12.09) is starting it takes about 30 to 40 seconds to bring up the splashscreen.
I found out, that the problem is mainly related to the process of getting a license from the license server.

The Client is requesting the feature "ZW2D_EDU" waits 10 seconds, requests "ZW2D_PERSONAL" waits 10 seconds and will finally request "ZW2D_PRO" which will result in a valid license.

The server is running on Windows Server 2016 and the Client Windows 10 1607

--------------------
21:22:01 (lmgrd) Server's System Date and Time: Sat Jan 07 2017 21:22:01 Mitteleuropäische Zeit
21:22:01 (lmgrd) pid 7684
21:22:01 (lmgrd) SLOG: Summary LOG statistics is enabled.
21:22:01 (lmgrd) Detecting other license server manager (lmgrd) processes...
21:22:01 (lmgrd) Done rereading
21:22:01 (lmgrd) FlexNet Licensing (v11.12.0.0 build 136775 i86_n3) started on CORP-HYPERV (IBM PC) (1/7/2017)
21:22:01 (lmgrd) Copyright (c) 1988-2013 Flexera Software LLC. All Rights Reserved.
21:22:01 (lmgrd) World Wide Web: http://www.flexerasoftware.com
21:22:01 (lmgrd) License file(s): C:\Program Files (x86)\ZWSOFT\ZWSOFT 2017 Network License Manager ENU\LicenseFile.lic
21:22:01 (lmgrd) lmgrd tcp-port 27000
21:22:01 (lmgrd) (@lmgrd-SLOG@) ===============================================
21:22:01 (lmgrd) (@lmgrd-SLOG@) === LMGRD ===
21:22:01 (lmgrd) (@lmgrd-SLOG@) Start-Date: Sat Jan 07 2017 21:22:01 Mitteleuropäische Zeit
21:22:01 (lmgrd) (@lmgrd-SLOG@) PID: 7684
21:22:01 (lmgrd) (@lmgrd-SLOG@) LMGRD Version: v11.12.0.0 build 136775 i86_n3 ( build 136775 (ipv6))
21:22:01 (lmgrd) (@lmgrd-SLOG@)
21:22:01 (lmgrd) (@lmgrd-SLOG@) === Network Info ===
21:22:01 (lmgrd) (@lmgrd-SLOG@) Socket interface: IPV6
21:22:01 (lmgrd) (@lmgrd-SLOG@) Listening port: 27000
21:22:01 (lmgrd) (@lmgrd-SLOG@)
21:22:01 (lmgrd) (@lmgrd-SLOG@) === Startup Info ===
21:22:01 (lmgrd) (@lmgrd-SLOG@) Is LS run as a service: Yes
21:22:01 (lmgrd) (@lmgrd-SLOG@) Server Configuration: Single Server
21:22:01 (lmgrd) (@lmgrd-SLOG@) Command-line options used at LS startup: -c C:\Program Files (x86)\ZWSOFT\ZWSOFT 2017 Network License Manager ENU\LicenseFile.lic -l C:\Temp\flexlm.log -z -s
21:22:01 (lmgrd) (@lmgrd-SLOG@) License file(s) used: C:\Program Files (x86)\ZWSOFT\ZWSOFT 2017 Network License Manager ENU\LicenseFile.lic
21:22:01 (lmgrd) (@lmgrd-SLOG@) ===============================================
21:22:01 (lmgrd) Starting vendor daemons ...
21:22:01 (lmgrd) Started zwflex (pid 2496)
21:22:01 (zwflex) FlexNet Licensing version v11.12.0.0 build 136775 i86_n3
21:22:01 (zwflex) SLOG: Summary LOG statistics is enabled.
21:22:01 (zwflex) SLOG: FNPLS-INTERNAL-CKPT1
21:22:01 (zwflex) SLOG: FNPLS-INTERNAL-CKPT2
21:22:01 (zwflex) Using options file: "zwflex.opt"
21:22:01 (zwflex) Server started on CORP-HYPERV for: ZW2D_PRO
21:22:01 (zwflex) EXTERNAL FILTERS are OFF
21:22:01 (zwflex) INCLUDE_ENTITLEMENT HOST_GROUP GRP_BORROW_INCLUDE xxxxx-xxxxx...
21:22:01 (lmgrd) zwflex using TCP-port 51442
21:22:01 (zwflex) SLOG: Statistics Log Frequency is 240 minute(s).
21:22:01 (zwflex) (@zwflex-SLOG@) ===============================================
21:22:01 (zwflex) (@zwflex-SLOG@) === Vendor Daemon ===
21:22:01 (zwflex) (@zwflex-SLOG@) Vendor daemon: zwflex
21:22:01 (zwflex) (@zwflex-SLOG@) Start-Date: Sat Jan 07 2017 21:22:01 Mitteleuropäische Zeit
21:22:01 (zwflex) (@zwflex-SLOG@) PID: 2496
21:22:01 (zwflex) (@zwflex-SLOG@) VD Version: v11.12.0.0 build 136775 i86_n3 ( build 136775 (ipv6))
21:22:01 (zwflex) (@zwflex-SLOG@)
21:22:01 (zwflex) (@zwflex-SLOG@) === Startup/Restart Info ===
21:22:01 (zwflex) (@zwflex-SLOG@) Options file used: zwflex.opt
21:22:01 (zwflex) (@zwflex-SLOG@) Is vendor daemon a CVD: No
21:22:01 (zwflex) (@zwflex-SLOG@) Is TS accessed: Yes
21:22:01 (zwflex) (@zwflex-SLOG@) TS accessed for feature load: Sat Jan 07 2017 21:22:01 Mitteleuropäische Zeit
21:22:01 (zwflex) (@zwflex-SLOG@) Number of VD restarts since LS startup: 0
21:22:01 (zwflex) (@zwflex-SLOG@)
21:22:01 (zwflex) (@zwflex-SLOG@) === Network Info ===
21:22:01 (zwflex) (@zwflex-SLOG@) Socket interface: IPV6
21:22:01 (zwflex) (@zwflex-SLOG@) Listening port: 51442
21:22:01 (zwflex) (@zwflex-SLOG@) Daemon select timeout (in seconds): 1
21:22:01 (zwflex) (@zwflex-SLOG@)
21:22:01 (zwflex) (@zwflex-SLOG@) === Host Info ===
21:22:01 (zwflex) (@zwflex-SLOG@) Host used in license file: CORP-HYPERV
21:22:01 (zwflex) (@zwflex-SLOG@) Running on : Physical
21:22:01 (zwflex) (@zwflex-SLOG@) LMBIND needed: No
21:22:01 (zwflex) (@zwflex-SLOG@) LMBIND port: -NA-
21:22:01 (zwflex) (@zwflex-SLOG@) ===============================================
21:22:24 (zwflex) TCP_NODELAY NOT enabled
21:22:24 (zwflex) UNSUPPORTED: "ZW2D_EDU" (PORT_AT_HOST_PLUS ) user@CORP-CLIENT (License server system does not support this feature. (-18,327))
21:22:33 (zwflex) UNSUPPORTED: "ZW2D_PERSONAL" (PORT_AT_HOST_PLUS ) user@CORP-CLIENT (License server system does not support this feature. (-18,327:10054 ""))
21:22:42 (zwflex) OUT: "ZW2D_PRO" user@CORP-CLIENT
--------------------

I have tried to enable the TCP_NODELAY option, with no luck, but getting an "IN" log at the end:
--------------------
21:19:40 (zwflex) TCP_NODELAY enabled
21:19:40 (zwflex) UNSUPPORTED: "ZW2D_EDU" (PORT_AT_HOST_PLUS ) user@CORP-CLIENT (License server system does not support this feature. (-18,327))
21:19:49 (zwflex) UNSUPPORTED: "ZW2D_PERSONAL" (PORT_AT_HOST_PLUS ) user@CORP-CLIENT (License server system does not support this feature. (-18,327:10054 ""))
21:19:58 (zwflex) OUT: "ZW2D_PRO" user@CORP-CLIENT
21:20:11 (zwflex) IN: "ZW2D_PRO" user@CORP-CLIENT
--------------------

Is there a way to change the order of the license request?

Severin

Rank: 5Rank: 5

Jeffrey_ZWCAD

posts: 563

Registered: 2015-6-9

Message 2 of 4

10-01-2017 10:03 . am   |   View his/her posts only
Reply 1# s.meyer

Hi, thanks for your feedback.We confirm that this is due to a bug (T12738) in the license manager, the pro/std licenses should be checked first instead of edu/personal.
And since the mechanism is written inside the code, it is barely possible to change the order outside. We will push it to be solved ASAP. Any progress, will let you know.

Thanks again.

Rank: 1

s.meyer

Newbie

posts: 2

Registered: 2011-12-23

Message 3 of 4

10-01-2017 05:00 . pm   |   View his/her posts only
Reply 2# withje8478

Thank for your answer.
I think changing the order will only be a workaround for those who have a pro license.
So will there be a fix, that the license process is taking 10 seconds for each request?

Regards
Severin

Rank: 5Rank: 5

Jeffrey_ZWCAD

posts: 563

Registered: 2015-6-9

Message 4 of 4

11-01-2017 01:40 . pm   |   View his/her posts only
Reply 3# s.meyer


Hi, on some other tests, it won't take 10s to get the floating license, and actually it just takes 1s to go through these three licenses and get the pro one. So it may be related to some certain network environments, for example, the license server is located outside the company network. When the bug of order to get license is fixed, till then we can check whether the speed is OK or not.
See also
X